Jump to content

Recommended Posts

So last night I changes hoses over on my 2 reels. The o-ring on on my qc fitting had came out and I didnt realize it. When I put air to the pump, ya, SH everywhere. Pulled the air and put a new o-ring in. When I put some water thru the pump, it would pulsate like hell (never did before) and slow to a crawl. Compressor was on maybe 5 minutes. On the job today and it did the same thing plus it stalled a few times. Disconnected the air quick disconnect and plugged back in. Ran ok except the pulsating which wasnt all the time. I did notice clicking in the pump when spraying which I didnt notice before but I may have not payed that much attention to it since it was new 3 years ago. Any thoughts?

1/2" Yamada kynar NDP-15-FVT-ECO

Very little moisture in air lines.

Thanks

Edited by ReNew Roof & Exterior cleaning

Share this post


Link to post
Share on other sites

So last night I changes hoses over on my 2 reels. The o-ring on on my qc fitting had came out and I didnt realize it. When I put air to the pump, ya, SH everywhere. Pulled the air and put a new o-ring in. When I put some water thru the pump, it would pulsate like hell (never did before) and slow to a crawl. Compressor was on maybe 5 minutes. On the job today and it did the same thing plus it stalled a few times. Disconnected the air quick disconnect and plugged back in. Ran ok except the pulsating which wasnt all the time. I did notice clicking in the pump when spraying which I didnt notice before but I may have not payed that much attention to it since it was new 3 years ago. Any thoughts?

1/2" Yamada kynar NDP-15-FVT-ECO

Very little moisture in air lines.

Thanks

It might be an air motor going bad

Share this post


Link to post
Share on other sites

It is possible that there is water in the system and I need a new muffler o4 I will take that one off to see if that helps.  I have been wanting to get another pump possibly 3/4". Having only one pump is kinda risky.

Will definitely get a air motor for the Yamada if thats the issue.

Kevin, do you have any 3/4" pumps for sale?

Share this post


Link to post
Share on other sites

It is possible that there is water in the system and I need a new muffler o4 I will take that one off to see if that helps.  I have been wanting to get another pump possibly 3/4". Having only one pump is kinda risky.

Will definitely get a air motor for the Yamada if thats the issue.

Kevin, do you have any 3/4" pumps for sale?

Nope...no 3/4" pumps at this time. Very low on inventory, we are out of the industrial upgrade cycle right now. That being said, most 3/4" pumps, with a few choice exceptions, are just 1/2" pumps with 3/4" manifolds. A higher output 1/2" or a very efficient 1" pump (assuming you have enough CFM) may be a possibility. 

As for the problem, check to see you don't have a stuck valve on one side which would mean only one chamber is pumping. That can cause it to vibrate and click. 

Share this post


Link to post
Share on other sites

Ok. I do want the 1"poly pump. I'll have about 17cfm, hope thats enough.

My Yamada is clicking loudly and there may be gunk in the pump. I took off my muffler and there is a combination of water gunk with oil from the compressor inside the muffler.

Edited by ReNew Roof & Exterior cleaning

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×